AppImage的使用初探



  • AppImage依赖cmake,因此我们需要安装cmake。命令是:

    sudo apt install cmake
    

    AppImage还依赖libtool,因为我在cmake进行configure的时候,出现了以下的错误:

    CMake Error at CMakeLists.txt:60 (message):
    Could not find required program libtoolize.
    Call Stack (most recent call first):
    CMakeLists.txt:70 (check_program)

    因此我们还必须安装libtool才行,命令是:

    sudo apt install libtool
    

    在configure的时候,又出现了以下的错误:
    -- Checking for module 'glib-2.0'
    -- No package 'glib-2.0' found

    看来我们还得安装这个才行

    sudo apt install libgtk2.0-dev

    后面觉得安装AppImage实在是太麻烦了,干脆下载AppImage自己的每日版。在使用AppImage的时候,偶然发现了符合我们需要的linuxdeployqt这个软件,太好了,如获至宝。赶紧学习linuxdeployqt这款软件的使用方法,于是AppImage的学习就草草地结束了。


登录后回复
 

与 萌梦社区 的连接断开,我们正在尝试重连,请耐心等待