改进Qt for Android 开发环境(Qt 5.5.1) 第一章



  • 前言:之前写过搭建Qt for Android 开发环境(Qt 5.5.1),本次是一些改进

    从Ant到Gradle

    之前Qt配置环境时候,使用的是Ant构建APK,但官网说不再支持使用Ant来构建APK。

    0_1522300262118_1.png

    因此改用Gradle构建APK

    要安装Gradle,打开Gradle官网,官网说可以用Chocolatey安装Gradle,并给出安装命令

    0_1522300336846_2.png

    要安装Chocolatey,打开Chocolatey官网,官网说用管理员权限运行cmd.exe,输入以下命令

    @"%SystemRoot%\System32\WindowsPowerShell\v1.0\powershell.exe" -NoProfile -InputFormat None -ExecutionPolicy Bypass -Command "iex ((New-Object System.Net.WebClient).DownloadString('https://chocolatey.org/install.ps1'))" && SET "PATH=%PATH%;%ALLUSERSPROFILE%\chocolatey\bin"
    

    0_1522300601832_3.png

    Chocolatey安装完成后,验证版本

    0_1522300649675_4.png

    继续安装gradle

    0_1522300751765_5.png

    输入Y,回车,继续安装

    等了很久很久,安装失败了,很绝望

    0_1522305932771_QQ截图20180329144513.png

    不甘心,又找到一个网址,有所有版本的Gradle,地址,下载了gradle-4.6-bin,解压到C:\Grandle

    0_1522306230720_QQ截图20180329145022.png

    配置环境变量

    0_1522306296907_QQ截图20180329145123.png

    0_1522306338218_QQ截图20180329145207.png

    命令行验证

    0_1522306357437_QQ截图20180329141407.png


    未完待续



  • @青山白云改进Qt for Android 开发环境(Qt 5.5.1) 第一章 中说:

    等了很久很久,安装失败了,很绝望

    学到了新知识!那就是chocolately这个Windows的安装包。有了这个,看来很多软件只需要一个命令就可以获取到了呢。


 

走马观花

最近的回复

  • @chinasmu Webkit网络的部分可能不是受到Qt控制的,扩展性较差,所以呢,还不能通过代码的方式侦听网络收发数据。但是WebEngine就可以。如果可以的话,试试Qt WebEngine。😺

    阅读更多
  • C

    我用qt建了个对话框程序,里面加了个webkit,请问有办法获取该控件的全部网络封包通信数据吗?
    不采用windows hook recv和send函数的形式,或者有没有第三方的控件可以这样做

    阅读更多
  • 这个错误不是编译器的错误,而是IntelliSense的错误。
    这种情况,可以不用太担心。

    如果你使用MSVC编译应用程序,那么最好安装Qt Visual Studio Addon,使用这个插件同步开发Qt应用程序。
    不过一个小小的建议,就是Qt Creator写Qt程序非常直观,不需要在Visual Studio中那么麻烦,而且Qt Creator是强制安装的,基本上你安装了Qt 5.12,就可以在安装的目录中找到它。QAxContainer是Qt的模块activeQt中的,需要在pro文件中写QT += axcontainer,才会找到这个类。

    阅读更多
  • C

    VS2017 Qt5.12
    新建一个空的QWidget对话框,编译执行
    可以成功生成并执行,但是错误列表里显示

    傲游截图20190217212931.png

    exe文件能够成功生成。

    另外的问题:我在vs2017编译环境中使用qt,需要用到 QAxContainer,我看帮助文档里说要在.pro中加入CONFIG+=qaxcontainer,但是vs2017创建的程序中没有.pro这个文件,那这句话应该加在哪里呢?

    还有我想建一个有浏览器控件的对话框程序,如果想在5.12版本中加入QtWebKit应该如何使用

    阅读更多

关注我们

微博
QQ群











召唤伊斯特瓦尔