嵌入式板子上运行Qt的程序,无法显示界面,报错误



  • 错误信息是:
    ./TestProject: /usr/lib/libQt5Qml.so.5: no version information available (required by ./TestProject)
    ./TestProject: /usr/lib/libQt5Core.so.5: no version information available (required by ./TestProject)
    ./TestProject: /usr/lib/libQt5Gui.so.5: no version information available (required by ./TestProject)

    屏幕不显示任何内容。
    不清楚是什么原因导致的。想知道这个是什么原因。



  • 后面查到原因是因为这个板子的Qt程序和烧的Qt运行环境版本不一致导致的。需要烧运行环境版本和开发的Qt版本一致的系统。


Log in to reply
 

走马观花

最近的回复

  • 自己顶顶有益健康

    read more
  • @qyvlik 这个例子可否提供学习一下?

    read more
  • @zhoujin7 这个是PySide的代码。的确有深度……
    还要配置环境才可以顺利地跑通你的代码呢。

    read more
  • 这个可以自由拖动, 但是不能自动对齐, 不是我需要的效果

    read more

关注我们

微博
QQ群